2014年12月11日木曜日

Eclipse Android SDKをrev 24.0.1にしたらUnable to execute dexエラーではまった!

Android SDKをrev 24.0.1にしたら、

[2014-12-11 16:56:27 - Dex Loader] Unable to execute dex: com.android.dx.dex.code.DalvInsn.withMapper(Lcom/android/dx/ssa/RegisterMapper;)Lcom/android/dx/dex/code/DalvInsn;
[2014-12-11 16:56:27 - プロジェクト名] Conversion to Dalvik format failed: Unable to execute dex: com.android.dx.dex.code.DalvInsn.withMapper(Lcom/android/dx/ssa/RegisterMapper;)Lcom/android/dx/dex/code/DalvInsn;


上記エラーメッセージではまった!


対処方法

1.プロジェクトのクリーン
2.Eclipseのクリーン起動での再起動
     コマンド  /Applications/eclipse/Eclipse.app/Contents/MacOS/eclipse -clean
3.プロジェクトのビルド

なんか、アップデートするたびに、なにかのエラーで頭を悩ましてます。



1 件のコメント:

  1. 同様の症状が出て困っていました。
    とても助かりました。ありがとうございます。

    コマンド
    cd C:\Program Files\eclipse4.3\eclipse
    eclipse -clean

    返信削除